Many Jifty frontend functionality are provided by javascript, like time picker, calendar picker, etc. It is a big load if they ended up not being used. You can provide a start method in MyApp.pm to override the default javascript. However, some of them are always required (like jQuery). I figured that this might be the minimum:

package MyApp;

sub start {
    Jifty->web->javascript_libs([qw[
        jquery-1.2.6.js
        jquery.jgrowl.js
        behaviour.js
        jquery.timepickr.js
        jifty.js
        jifty_utils.js
        jifty_subs.js
        jifty_smoothscroll.js
        app.js
    ]]);
}

Hmm, maybe it's time to upgrade jQuery to 1.3.2 for Jifty.