最近繼續用 Jifty 亂寫東西,配合 OpenID,但發現目前在 CPAN 上的 Net::OpenID::Consumer 無法配合 Yahoo 的 OpenID。研究之後發現是因為 Yahoo 只提供 OpenID 2,而目前釋出的 Net::OpenID::Consumer 尚未支援 OpenID 2。

有必要使用的人,建議直接安裝 sixapart svn裡面的版本:

http://code.sixapart.com/svn/openid/branches/openid2/perl/Net-OpenID-Consumer/

自已測試之後,可用 Yahoo 與 Google 的 OpenID。

Labels: jifty, openid, perl